Sign In

Muxing 4K83 issue

Author
Time

Hi, anyone else get this error when muxing 4K83 in tsMuxerGUI?

“Reading buffer overflow. Possible container streams are not syncronized. Please, verify stream fps.”

Anyone know how to solve it?

Author
Time
 (Edited)

This has a few suggestions to try and overcome the same issue:-

https://forum.videohelp.com/threads/370533-tsMuxeR-giving-Reading-buffer-overflow-error-at-47-4

and the 3rd post down (and onwards) in here - https://forum.doom9.org/showthread.php?t=175120&page=4
 

and the forums at http://www.thestarwarstrilogy.com may also be a good place to see if others have had the same / similar issue and how they overcame it.

Good luck with it mate 😃
 

originaltrilogy.com Moderator

I find that answer vague and unconvincing. Why don’t you knock it off with them negative waves?
Why don’t you dig how beautiful it is out here? And say something righteous and hopeful for a change?

Author
Time

What exactly are you muxing? Almost sounds like you’ve loaded two MKV files into it and left both video streams checked?

a trolling bantha

Author
Time

I am having an issue with muxing 4K83 v1.3 to a BD iso file to burn to disc.

Twice now TSmuxer gets 99.4% complete and then posts error code 1073741819. I googled the error code and found an old message board where a guy was getting this code when he accidentally had two VC-1 codecs checked. Deselecting one fixed his issue.

My problem is, I don’t know what the heck any of that means. And I’m not sure what to do to make it work. I’ve been doing the exact same thing I always do muxing my iso files and this one is stumping me.

I only add one file to be muxed: the actual mkv of the film (I tried including the little intros and rating card one time but failed miserably so now I just keep it simple; a disc of the film itself with the included chapter stops).

Any ideas what is happening and how I can fix it?

Author
Time

Try first demuxing the video stream into its own .264 file, then using that .264 file as your video source when muxing the ISO.

I think some people over at the project’s forums had the same issue and this was the best solution, but I could be misremembering…

a trolling bantha

Author
Time

Thanks for the info. Is there a place where I might find guidance on how to demux and remux into this .264 file? This is all very Greek to me. I’ve managed to mux MKV to a BD iso, but that’s as far as I’ve ever made it. I know people do things like adding and removing audio and video tracks but I have no idea how to do any of that.

Author
Time

You’re using tsmuxer to make your BD ISO, right? Use the same program to demux - check only the video stream, then select the “demux” option instead of the “Blu-Ray ISO” option before you run the operation.

When it’s done, close tsmuxer, then reopen it. Open the .264 file you created in the previous step, then open the MKV, uncheck the video stream from the MKV, and proceed as before, though you’re pretending now that the .264 file you opened first is the video track from the MKV file (which it is, really, but something about it as contained within the MKV file isn’t playing nice).

a trolling bantha

Author
Time

Awesome, thank you for the help!

So I just want to make sure I’m understanding the concept behind what you’re saying…

Your instructions have me demuxing the original mkv to separate out the video stream. Then when I mux the iso file I need to add the original mkv but deselect the video stream (so I’m basically using the audio portion of the original mkv), then add in the newly created video stream? Is that correct.

I find when I understand the concept behind them, I usually have less trouble following the instructions correctly. But all this video and audio manipulation and “computer stuff” is so far outside my wheelhouse that I really struggle to keep up with some of you guys!

Author
Time

Yep, that’s pretty much it. Isolate the video stream out into its own file (“demux” it), then use this new video-only file to create the ISO, while adding all the audio/subtitle tracks and chapters from the MKV back in (which is why you deselect the video track from the MKV).

I’m not guaranteeing this will work, but I do remember it being a workaround people on the 4K77/83 forums were using when tsmuxer didn’t play nice with the MKV as is.

a trolling bantha

Author
Time

Unfortunately that didn’t work. I got the same error at the same 99.4% completion when demuxing as I did when muxing. I did notice that TSmuxer had some additional info in a little window near the bottom. It said something about the streams possiby being out of sync or something like that (I really should’ve screenshotted that…)

Anyway, I’m wondering if somehow the MKV was corrupted or incomplete. I decided to just scrap it and start over, so I deleted the MKV and am currently re-downloading it. hope it works this time! What’s odd, though, is that VLC had no problem playing the MKV. But I didn’t actually watch the whole film, just spot checked it. Perhaps VLC would’ve locked up once it reached the broken part. I’ve seen VLC do that before, where you have a failed download that will play fine until it reaches the broken bit.

Author
Time

Hmm, that makes sense. Sorry you’re having so much trouble with it. I do know that I remuxed it with PCM audio tracks for myself, but can’t remember which version I used…

a trolling bantha

Author
Time

Ugh. I deleted everything, downloaded it fresh, and I’m still getting that same error at 99.4% when trying to mux a BD iso.

I don’t know what else to do. :’(

V1.3 looks so much better than the version 1.0 that I currently have (as amazing as it is). The colors and contrast are amazing! I’m not giving up but I’m gonna have to start digging harder to figure out what the problem is and how to solve it.

Author
Time

Alright! Got a solution. Seems it’s the audio tracks are causing the problem. I was able to demux (and got that error again at 99.4%). Then I successfully muxed (to 100%) a BD iso using just the video and only one audio track (the first one). I’m gonna repeat the process muxing by adding one track at a time until I find the culprit, then just leave that one out of the final iso. It’ll take a few days probably, but I’ll report back when I know which track is causing my issue in case it helps anyone else.