Sign In

how to get back to 16:9?

Author
Time

um hey guys i am stuck again! lol.  i dont know whats going on but i rendered my edit out of vegas in lagarith and then tried to encode to mpeg2 in cce. first off cce locked up. then i looked at the little bit of video it did encode and it is still in 3:2 ar. its weird because i did a test clip in cce a few days ago and set the ar to 16:9 and chose 3:2 pulldown and the clip came out fine. however that clip was from vdub that i had rendered out to lagarith. after running the file through vegas something went wrong. so is there another encoder you guys can suggest? i have downloaded hc encoder but dgindex wont work with the lagarith file to create a d2v to load into hc. i dont know how to make an avs script. so i am s.o.l.  i put it into tmpgenc and chose 16:9 3-2 pulldown and checked the preview and nope its not going back to 16:9. so i guess i still do not get how to bring the 3:2 file back to 16:9. can someone elaborate on how this is done and what the problem may be with cce? thanks again everyone.

believe in the ball and throw yourself!

Author
Time

3:2 pulldown is something completely different than what you're trying to use it for.

3:2 pulldown is applied to progressive 23.976 (or 24) frames per second material in order to bring it to interlaced 29.97 frames per second.  The reason it's called 3:2 pulldown is because of the cadence that this results in - frame 1 becomes 2 fields, frame 2 becomes 3 fields, frame 3 becomes 2 fields, frame 4 becomes 3 fields, and so on - 2:3:2:3.  (The term is technically supposed to be 2:3 pulldown, but that and 3:2 are sort of used interchangeably.)

What you need to do is set an anamorphic flag.  I don't know how you'd do this in the programs you're using, though, so someone else is gonna have to help you there.

Also, I'm not 100% sure if you do need to apply the 2:3 pulldown now, or not.  That whole business confuses me, since DVDs display with 2:3 pulldown on 480i/1080i TVs, but they can display without it on 480p/720p/1080p TVs.  So I'm not sure if you can encode without the 2:3 pulldown and let the player do it itself, or if you need to encode with it from the start.

Author
Time

hehe yeah! idk ash its all confusing to me bro aspect ratio,pulldown,resolution its a little much to swallow though i find myself reading about it constantly it just does not sink in. however in cce 2:3 or 3:2 pulldown is only selectable when 23.976 is your framerate.if 29.970 is chosen i can  not use 3:2 pulldown. either way it is not stretching the picture back to 16:9 and in 3 encoders i have tried all the settings pertaining to aspect ratio and none seem to change it from 3:2.

believe in the ball and throw yourself!

Author
Time

The encoder sets the video to play 16:9 in your player, you won't see it until you play it.

Author
Time

ibleedspeed said:

3:2 pulldown is only selectable when 23.976 is your framerate.if 29.970 is chosen i can  not use 3:2 pulldown.

Exactly, because that's what 3:2 pulldown is - a method of translating 24 frames per second into 30 without speeding up the film.  To go from 30 back down to 24, you just need to remove the pulldown, or do an inverse telecine if the transfer was at 30fps to begin wtih (like your Volume 2 DVD).

(Note that, as I'm getting sick of typing 23.976 and 29.97 all the damn time, I'm rounding up to 24 and 30, even though neither one of those is entirely accurate.)

Author
Time

d2v files are frame indexes for mpeg2 video.  You can't create a d2v file for an avi.

HCEncoder accepts either .d2v or .avs input, so to use it on your project you'll need to install AviSynth and create a simple script to tell it what video to load.  The command for this is AviSource("path for your video file").  The .avs script is just a simple plain text file with the extension renamed.

As ChainsawAsh said, 3:2 has to do with the frame rate, not the aspect ratio of the image.  Valid dvd aspect ratios are 16:9 and 4:3.

If your video source is film-based, you'll want to encode as progressive video so you don't waste space with repeated fields.  The rendering is still ultimately interlaced, but properly set this way it will be easily de-interlaced back into the original frames on a progressive display.  3:2 pulldown and 16:9 aspect ratio should be flagged into the video stream during the mpeg2 encoding stage.  On a display supporting 23.976 fps, the pulldown flags simply identify which fields belong to which frame, but the speed alternation does not take place.  However, sophisticated de-interlacers do not rely on the flags alone because otherwise errors will be seen any time there is a cadence change or other irregularity; instead they analyse the image in advance and base their frame assembly on algorithms that identify patterns of change in the video.

Author
Time

Well, if you're looking at a 720x480 image with square pixels, it's a 3:2 aspect ratio, so I can understand the confusion.  But since digital NTSC video isn't square pixels, 720x480 is 4:3.

Author
Time

Calling the video stream 3:2 is needlessly confusing, yeah.  That is technically its ratio, but a dvd will never display this way in proper playback, so it's better just to call it 720 x 480, and flagged either as 4:3 or 16:9.  Once the video file is at the right resolution, the flags set during encoding take care of the horizontal width, no need to mess with it other than that.

Author
Time

ok i get it now. but upon trying to encode it both cce and tmpgenc freeze. i dont know why because i did an os reboot right before i edited this to make sure i had a clean system with as little video gear as possible. the only installed programs for video are adobe ae and premier, gordian knot, cinema craft and tmpgenc. but there must be a conflict with something. right now i have 2 choices either learn how to make the .avs script and try hcencoder  or reboot again and install nothing but my encoder. of course this means copying the 53 gb edit over to an external and then copying it back to the new os.  either way i am on the last encoding step and now it decides to be a royal pia.. i did a search on cce freezing and it seems it is a problem for a lot of people.support basically said its a problem with your computer. the usual generic answer. this sucks but i am about to start uninstalling everything on this computer.

believe in the ball and throw yourself!

Author
Time

well i dont know! but here see this i rendered out of sony vegas as an mpeg2 720x480 16:9 i then loaded it to dvd architect and chose 720x480 16:9 and this is what i got after making a test dvd. ichose 16:9 in every step i possibly could and it does not work.

believe in the ball and throw yourself!

Author
Time
 (Edited)

Choosing 16:9 every time might have been your issue, honestly.  Not sure though, as I've said before I'm not an expert in Vegas (or DVD Architect, for that matter).

Try rendering to MPEG2 from Vegas as 720x480, but don't choose 16:9 anywhere.  When you bring it into DVD Architect, set it as 16:9 there.

Author
Time

ChainsawAsh said:

...I'm not an expert in Vegas (or DVD Architect, for that matter).

Try rendering to MPEG2 from Vegas as 720x480, but don't choose 16:9 anywhere.  When you bring it into DVD Architect, set it as 16:9 there.

In Vegas (in the 'Save as type:') you can choose 'MainConcept MPEG-2', and then (in 'Template) choose 'DVD Architect 24p NTSC Widescreen video stream'.

It will set the video size at 720x480, and the Pixel Aspect Ration to 1.212 , etc..

This can be loaded into DVD Architect perfectly.

Then, you can do the sound separately, using 'Dolby Digital AC-3 Studio'.

Then set your project (in DVD Architect) to 16:9.

Star Wars Episode XXX: Erica Strikes Back

         Davnes007 LogoCanadian Flag

          If you want Nice, go to France

Author
Time

i used avspmod to make avs script for hcencoder. failed with an error invalid input convert to yuy12 or something like that. WOW!!!!! the force is not with me on this one guys. it will be hard to remember it all but i am going to try and post step by step what i did and hope you guys can see an error. so here it goes.

1 dgindex with forced film enabled.

2 gordian knot to create an avs script set to 720x480. (it came out as 3:2 dar)

3 loaded avs script into vdub exported as lagarith avi.

4 loaded both video sources and both 6 channel mono wav files into vegas and edited.

5 exported from vegas as lagarith avi 720x480 dar=3:2 par=1.2121

6 loaded to cce and watched all my hard work pan out to frozen encoders.

7 panic, beg for answers try uninstalling reinstalling everything. and then try to export to mpeg2 directly from vegas and still never get it to display at 16:9.

8 realize that i manually subbed 2 complete films for a total of 26 hours of work just on the subs and it looks like it was a complete waste of time because some step prior to editing was done incorrectly.

i dont know man but i am stressing over this because i do not want to do those subs again.

if i exported from vegas as mpeg2 using the ntsc dv widescreen 16:9 template this should add the 16:9 flag for dvd architect right? well it does not work. so to me this says there is something wrong with the lagarith sources i used. could it be that they came out of vdub as a total size of 720x480 including the black frame on all sides? this would explain it. instead of coming out as 720x480 for just the video for some reason i dont understand it included the frame as part of the pixels. so when i add the 16:9 flag it does for sure change it. but it does not know that the black bars are not part of the picture. i am just pulling at strings here but does anyone think this is what happened? if so then my edit is trash and i am back to square 1

believe in the ball and throw yourself!

Author
Time

i did exactly everything davnes007 said and the black bars do not go away. so this is almost proving my theory above. somewhere along the line the black bars became part of the 720x480 picture. this means the software that did this was gordian knot when i made the avs script. of which i had followed the instructions in adm,s guide to mpeg ac3 editing. this i believe is the straw that broke my edit. i am starting over. the only thing i can hope for is to save the subs in my project and just remove the video and audio sources and perform the edits again hoping that the subs line back up. this really sucks. i should have learned to make the script my self from the start.

believe in the ball and throw yourself!

Author
Time

ibleedspeed said:

5 exported from vegas as lagarith avi 720x480 dar=3:2 par=1.2121

This makes no sense, and is probably your problem.  720x480 will only have a DAR of 3:2 if the pixel aspect ratio is 1.  720x480 with a PAR of 1.2121 is 16:9.  You're confusing the encoder.

Author
Time

ChainsawAsh said:

ibleedspeed said:

5 exported from vegas as lagarith avi 720x480 dar=3:2 par=1.2121

This makes no sense, and is probably your problem.  720x480 will only have a DAR of 3:2 if the pixel aspect ratio is 1.  720x480 with a PAR of 1.2121 is 16:9.  You're confusing the encoder.

so then you are saying i need to export with 1.0 par ash? ok i will try that. my above theory of the black bars becoming part of the dar was wrong.  so maybe this is the answer. thanks again bro. i will have to find a way to repay you for all you have done ash.

believe in the ball and throw yourself!

Author
Time
 (Edited)

ibleedspeed, are you using the templates in Vegas? First of all, your project settings should be:

Template: NTSC DV Widescreen (720x480, 29.970 fps)

Which would give you:
Width:720
Height:480
Pixel Aspect Ratio: 1.2121


Then, when you render, select the same template: (Project settings are independent from Render settings.) Click on the Custom button and go to the Video tab to change your codec.

<span class=“Italics”>MeBeJedi: Sadly, I believe the prequels are beyond repair.
<span class=“Bold”>JediRandy: They’re certainly beyond any repair you’re capable of making.</span></span>

<span class=“Italics”>MeBeJedi: You aren’t one of us.
<span class=“Bold”>Go-Mer-Tonic: I can’t say I find that very disappointing.</span></span>

<span class=“Italics”>JediRandy: I won’t suck as much as a fan edit.</span>