Sign In

Widescreen problems- VAFPI codec

Author
Time

Hi all!

This is a question for all the budding editors out there.

For my edit, I have ripped VOB's from the DVD and using TMPGEnc and the VAFPI codec, I am
"wrapping" the vobs in a "fake" .avi file (courtesy of VAFPI codec) whilch allows it to be edited in Premiere as if the file was a true .avi file.

My problem is, the widescreen ratio is being lost somehow.

The new .avi created by the vafpi codec is stretching the movie vertically. This is before any compressing or encoding or editing! The movie is not being displayed in it's original widescreen presentation.

I can't explain why as I am not modifying the vobs in any way, simply wrapping them in a fake .avi file to be edited.

Does anyone have a solution???

Help me originaltrilogy.com, you're my only hope....
Author
Time
"Pass on what you have learned."

I had the same problem with an edit I was working on.

Is the source you're using anamorphic widescreen 1.78:1? If so, you're probably running into the same thing I was. With anamorphic widescreen the black bars aren't burned into the movie. The .vob files have a tag attached to them that lets your dvd player know that it is anamorphic widescreen and it adjusts automatically.

Thing is, as long as that tag is still attatched to the file you should be fine. You can perform a simple test to make sure you're okay. All you need to do is export and render about 30 seconds of footage as an .avi or quicktime file. When you open it the black bars should magically appear on the top and bottom and you will see there is no reason to worry. Make sure check your video in full screen mode to check for the bars.

I don't know much about aspect ratios and such, but someone pointed this out to me when I had this question and I am doing my best to pass on that information. I hope this helps.
Author
Time
Originally posted by: Rebel11_38
With anamorphic widescreen the black bars aren't burned into the movie.


That is not universally true. It is only true for material that is exactly 16:9; anything else -- like Star Wars, at 2.35:1 -- will also have black bars as part of the movie.

@Dantha Fodder: Chances are good that even though Premiere displays the picture without horizontal stretching, it's still fine. As long as it's re-encoded with the 16:9 flag set, all will be well.

As suggested, the render-and-test routine is the best way to ensure everything's working properly.

Author
Time
Actually, I knew that 2.35:1 has black bars encoded. Since I didn't know why a DVD at 2.35:1 has them and one at 1.78:1 doesn't though, I just decided to generalize . Thanks for clearing that up Kary.
Author
Time
Thanks for the advice guys. :=)

The black bars are part of the movie and DO appear.

However the image is still stretched vertically.

Unfortunately Karyudo, when I load the "fake" avi into Premiere and then export the finished .avi, it still exports the video as stretched. So when I load the finished AVI into my DVD burning software, the image is stillstretched.

Hmmmm.....not sure where to go from here.
Author
Time
What's the aspect ratio of your source?

Can you outline your editing process? If we know what you're doing, perhaps we can help you out of your pickle.

It could have something to do with the way you're creating a fake .avi. I use VirtualDub-MPEG to save the .vob files as .avi files and then load them into Premiere.
Author
Time
Howdy,

I think you just have the source aspect ratio set incorrectly. Check out the following screenshot and make sure you have it set like so in TMPGENC. Then save the project, regenerate the "fake AVI" from that newly saved project, and then try the export again.



http://www.dor-lomin.com/ot-images/widescreen-setting.gif
Author
Time
Thanks for all the replies guys, it really is appreciated!

I must apologise though, as I mentioned the wrong program in my original posting.
Sorry!

Rebel 11_38, the original source of my DVD is:

Resolution: 720 x 576
Aspect Ratio: 16:9

and this is the process I am following:

(1) Using SmartRipper I rip the VOBS

(2) Using DGMPGDEC (not TMPGENC as I wrongly stated in my first posting!) I convert the VOB's to a .d2v file.

(3) Using the VFPAI program, I convert the .d2v file into a "fake" .avi file.

Now when I double click this "fake" .avi file, it reads the original vobs and opens the movie in my DVD player software. Immediately I notice that the widescreen format has been lost and the movie is stretched vertically.

There has been no compression or editing done so far, as you can see.

(4) I then import the "fake" .avi into Premiere and edit away....

So the widescreen presentation is being lost early in the procedure as you can see.

I think as Rebel 11_38 suggested, there is file on the original source DVD that tells the DVD player software or my actual DVD player (connected to the TV) how to present the movie- ie to present in widescreen. Is this correct?

Could one of the files below, on the source DVD, be the "tag" or file that controls this?:

Video_TS.BUP
Video_TS.IFO
VTS_01_0.BUP
VTS_01_0.IFO

If so, is it just a matter of adding these files to my EDITED DVD and the widescreen presentation should return????

The only solution I can think of for my problem, is copying the 4 files above (the .BUP's and .IFO's) to my edited DVD with my newly created edited VOBS and hope they "Talk" to my DVD player and tell it to present it in widescreen and NOT STRETCH the image.

Thanks again for everyone's help! Hopefully we're almost there! I look forward to your responses guys....