Sign In

Sony Vegas problem - I can't export a 23.976fps video with 5.1 sound


OK, I'm just learning how to edit HD video, so naturally I tried to create an "extended version" of Star Wars.


I ripped both the movie BluRay and the bonus BluRay, and taken the correct m2ts files. So after a few "tweaks" all my sources were m2ts files with 23.976fps video encoded as AVC, and one 5.1 ac3 track (the movie had of course DTS but I converted it to ac3 before putting it to Vegas).


I have done carefully all edits which I wanted and now I want to render the final movie. Since all my input files had 23,976fps and 5.1 ac3 audio, I of course want to render the video as a 23.976fps (I don't care about the codec/container right now) and 5.1 ac3 audio. How should I do this ?


I am using Sony Vegas Movie Studio HD Platinum 10.0.

My first attempt was an "m2t" - I thought it's the same as m2ts but definitely isn't :-) The file was encoded with the MPG codec (I don't really care), the framerate was correct (23.976 progressive), BUT - the audio was only MP2 stereo :-(


After changing the settings I was able to create a m2ts file, which had the video encoded in AVC, and the audio was correctly encoded as a 5.1 AC3, BUT the video is encoded as 29.97fps and I honestly can't watch it, the movement is completely unnatural (I guess because of the creation of unnecessary frames)


Any help ? I really want for the start just a video with 23.976 fps and 5.1 AC3 audio. Or what am I doing wrong ?


No I can't :-( I can only choose 29.97 or 25


So, under one video template you get 23.976 and 2.0, and under a different template you get 29. and 5.1 audio? I've never used the studio version, but I know it's more limited than the regular version. This might be one of those limitations. I would try going on the Sony forums and see if someone there can help.

<span class=“Italics”>MeBeJedi: Sadly, I believe the prequels are beyond repair.
<span class=“Bold”>JediRandy: They’re certainly beyond any repair you’re capable of making.</span></span>

<span class=“Italics”>MeBeJedi: You aren’t one of us.
<span class=“Bold”>Go-Mer-Tonic: I can’t say I find that very disappointing.</span></span>

<span class=“Italics”>JediRandy: I won’t suck as much as a fan edit.</span>


adywan said:

You could always render the video @23.976 and then render the audio as a 5.1 AC3 separately and then use TSMuxer to combine them into a MT2S file

That's exactly how I did it, I was just hoping I could do it directly :-) But thanks for the tip, it seems I have bought a crappy version of Vegas