Sign In

Problems Adding deleted scenes back into AOTC

Author
Time
This probably isn't the right forum for this, but I know someone on here would know.

I have started trying to add the deleted scenes from AOTC back into the movie. This is what I have done so far.

Ripped movie with dvd shrink.
Demuxed vob files with vobedit
Used besweet to encode the ac3 file into wav
Used Virtualdubmod to encode to huffyuv
I then load everything into Vegas Video, cut & paste until I get it just the way I want it.

I did this with Phantom Menace and I didn't have any problems, but with AOTC the deleted scenes are 29.97fps and the movie is 23.976. Not real sure how to go about converting these files. I'm thinking I need to ivtc them?

Any help would be appreciated.

"You were so preoccupied with whether or not you could...you never stopped to think if you should." - Ian Malcolm, Jurassic Park
Author
Time
Originally posted by: tjdavis1138


I did this with Phantom Menace and I didn't have any problems, but with AOTC the deleted scenes are 29.97fps and the movie is 23.976. Not real sure how to go about converting these files. I'm thinking I need to ivtc them?


Are you sure? I don't know why Lucasfilm would change framerates on the deleted scenes, as they are just finished scenes that were cut after weeks into postproduction.

Also, when you did this for TPM, did it work? I mean, I would think the wipes and such wouldn't work with just a cut and paste job. I would think you'd have to recreate the wipes.

The Jedi are all but extinct.......
Author
Time
I know it sounds stupid. I have no idea why they would be this way. Maybe someone else could check their disk and verify?

I loaded the deleted scenes into tmpg and they show as 29.97 were as the movie itself says 23.976. I didn't notice this until I started adding one of the scenes and the playback on that scene was too fast and the sound was out of sync. I have vegas set for 23.976.

I had to recreate all the wipes as well as fade the sound in and out. Pretty easy to do in vegas.
"You were so preoccupied with whether or not you could...you never stopped to think if you should." - Ian Malcolm, Jurassic Park
Author
Time
When a movie is normally encoded for an NTSC disc, it's done at 24fps (actually 23.976fps but we'll round up), and a flag is inserted to tell the DVD player to repeat every 5th field, producing the 30fps the TV needs. What's probably happened here is that the repeated field has been inserted as part of the video stream, probably due to the deleted scenes coming from videotape. If you put the 30fps video into VirtualDub-MPEG2, you'll probably see some frames are repeated as you step through.

DE
Author
Time
Those frames aren't repeated, they are blended together, part of the frame before, part of the frame following.

Author
Time
That doesn't sound good.

Any way to bring it back to the 23.976 fps?
"You were so preoccupied with whether or not you could...you never stopped to think if you should." - Ian Malcolm, Jurassic Park
Author
Time
Those frames aren't repeated, they are blended together, part of the frame before, part of the frame following.


Ah, that's why I said fields A field is half a frame - one field is the even numbered lines, the other is the odd numbered lines. By my reckoning there will be one "reconstructed" frame for every four full frames (eight fields), bumping 24fps up to 30fps - this isn't quite what I thought you were describing though, because:

I think, although I'm not certain, that when a DVD player does the bumping up, it repeats one field for every four original fields (2 frames) - the order of the two fields in a frame is reversed each time a field is repeated, but because the frames are progressive this makes no difference.

Sounds like, the way they've done it, that you can just delete the offending frames (which might take a while), save as a 23.976fps AVI and import that into Vegas.

DE
Author
Time
I stepped through the file frame by frame in Vegas and I can't tell which is the blended frame.

Jeez, didn't think it would be this difficult after doing TPM.

I do thank everyone for replying.
"You were so preoccupied with whether or not you could...you never stopped to think if you should." - Ian Malcolm, Jurassic Park
Author
Time
I tried doing something similar about two months back. Ripped the movie and deleted scenes with dvd shrink, converted the audio to mp2 with besweet, and I was able to edit it all together in tmpgenc dvd author with no frame rate problems at all.
Author
Time
I didn't have this problem myself, but it could just be a flag setting and not an actual difference in the encoding.
I am fluent in over six million forms of procrastination.
Author
Time
"I loaded the deleted scenes into tmpg and they show as 29.97 were as the movie itself says 23.976. I didn't notice this until I started adding one of the scenes and the playback on that scene was too fast and the sound was out of sync. I have vegas set for 23.976.

I had to recreate all the wipes as well as fade the sound in and out. Pretty easy to do in vegas."


It sounds like you need to set the pulldown flag on your new video, so it will pulldown like the original video. Google a file called "Pulldown.exe", though I believe it only works with elementary streams (and being a Vegas person like myself, I'm sure you know which box to check. If not, let me know. )

<span class=“Italics”>MeBeJedi: Sadly, I believe the prequels are beyond repair.
<span class=“Bold”>JediRandy: They’re certainly beyond any repair you’re capable of making.</span></span>

<span class=“Italics”>MeBeJedi: You aren’t one of us.
<span class=“Bold”>Go-Mer-Tonic: I can’t say I find that very disappointing.</span></span>

<span class=“Italics”>JediRandy: I won’t suck as much as a fan edit.</span>

Author
Time
I'm a newbie with Vegas so I'm not sure which box you mean.

I tried pulldown.exe and it didn't work. Just created a file with one frame and then stopped.
"You were so preoccupied with whether or not you could...you never stopped to think if you should." - Ian Malcolm, Jurassic Park
Author
Time
For some reason pulldown.exe will not convert frame rates from 29.970 to 23.976. To do this you can use two programs, both of which are available through doom9.net I believe. The first is called Cuttermaran and the second is called DVD Patcher version 1.06. You will first have to demux your mpeg2 video stream as Cuttermaran only works with elementary streams. Because of some unknown but useful glitch with Cuttermaran, the program does not recognize the flags for blending frames in mpeg2 videos and thus will only recognize the 23.976 fps frames actually encoded in the file. Select the entire timeline in Cuttermaran, add it to the cut list, and output the file. The new video will contain only the original 23.976 fps frames, but will play at 29.970 fps, giving a shorter video file that plays too fast. Use the second program "DVD Patcher" to fix this. Import the new video, make sure all settings in the program match the mpeg2 video stream, including the nominal bitrate, vertical and horizontal resolutions and aspect ratio (the program will show the original settings of the video prior to patching). Now change the frame rate to 23.976, check "patch entire file", and then patch. I think there will be a warning about changing the frame rate, but this can be ignored. Now you should have an elementary mpeg2 stream that runs at 23.976 instead of the telecined 29.970 you currently have. Consequently, you could also use pulldown.exe to change the rest of the film from 23.976 to 29.970, as this is necessary before creating the dvd anyway. Cheers

If I had some gum, I’d chew a hole into the sun…