Sign In

Avatars don't update

Replies
15
Author
Time

I have been trying to upload a new avatar since yesterday to no avail. Has this been happening to anyone else recently?

Author
Time

Clearing my cache worked but what’s funny is that the avatar didn’t change yesterday when I was on my Iphone. If anything I should have seen the new one on there instead of my computer.

Thank you Frank.

Author
Time

The problem is that Avatar images are served under your user ID, so the URL never changes. Also the http header allows for an enormously long caching time (Cache-Control: max-age=31536000). i see ETag is being used, but unless i am confused, that only applies once the max-age has expired?

A simple fix may be to serve the images by the pre-computed md5 hash of the actual image file, instead of the userid. it would mean an extra piece of data needs to be looked up for each user when loading a page.

Am i oversimplifying this?

Refreshing is annoying, especially on my android phone, where it seems i have to actually go into the site ‘storage’ settings to deleted cached data.

Author
Time

I have a problem where my Avatar is not showing up. I uploaded a small picture of Yoda with an Ewok and Gizmo.
Does anyone see my Avatar? I uploaded it again with no luck. I checked the site in a Chrome Incognito window, and it was displayed. Does anyone know how to fix it?

Thank You.

UPDATE: Nevermind, I finally got my Avatar to appear.

This post has been edited.

Author
Time

My avatar won’t show up… I loaded it in my account and it shows up there… but I can’t get it to load on threads

Author
Time

Try refreshing the page, or clearing your broswer cache. I can see your Lobot just fine. 😃

Where were you in '77?

Author
Time

Interesting - you have to clear the cache - forcing a full reload won’t do it.

To the top